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Installation
You should always make a back up of your data before updating any program, including CS Ledger. You are not
allowed to install the program in the root directory of any drive, including any mapped drives.
For network or multi-user installation, install the program on the computer that will hold the data. On each workstation,
create an icon to point to the program on the server using a mapped drive; for example:
TARGET = N:\...\csledger\csledger.exe
START IN = N:\...\csledger
We recommend you do NOT install the program under “Documents and Settings”, “My Documents”, “Program Files”,
“Windows”, or any of the Windows protected directories since this may result in the program not working due to
permissions and/or who is logged in.
When you re-install or update the program, only the program files are affected, not your data files. The easiest way to
update is from the program Help->Program Update. For heavy multi-user use, we recommend that write caching be
turned off; please see locking.rtf in your CS Ledger docs directory.
If you wish, you can run multiple companies and/or personal finance copies. To do this, simply install each one into a
different directory and have icons to run each. This allows you to run them simultaneously.
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General Setup
1.

select FILES -> SALES TAX
Edit these to reflect your sales tax. Every Customer and transaction must have a Sales Tax. CS Ledger has a
simplified method of addressing multiple taxing authorities, no matter how many different taxing authorities you
might have. Every customer has a specific tax rate, which is the cumulative tax of the various taxing authorities
affecting them.
Enter the number of Sales Tax items you need (you can always add more later). A vendor is used to separate the
taxes for reporting and is recommended even for non taxable. If you haven’t entered any Vendors yet, you can go
back later and add the Vendors here.

2.

In a similar manner, select FILES->LISTS->TERMS and FILES->LISTS->SHIP VIA and edit or add the items you
will be using. If you wish, you can add to or edit the other lists in FILES->LISTS now. However we suggest you
continue with setup now and go back and add or edit them later.

3.

select ADMIN -> SETUP and fill in the information on the various tab
“Jump to item entry” will jump to item entry after entering the customer or vendor (recommended)
“Print Ck Addr” will print the vendor address on checks (useful for mailing with window envelope)
Item # Input “Lookup” may be preferred if you have a large number of items; lookup is always used for item
entry by description.
The defaults you set here will automatically be entered whenever you create a new customer, vendor, or
transaction. As such, they should be the ones you commonly use. However, you always have the option to
change the default for each individual customer/vendor/transaction whenever you wish.
For Email or Fax, CS Ledger requires a postscript printer to be installed on the system. If necessary, install one in
windows and then reenter here and choose it. Note that you do not have to actually have the printer.
For Email, CS Ledger currently only uses MAPI. For MAPI, you must have an email client program such as
Outlook, Outlook Express, Windows Live Mail or any MAPI compliant program. If you use gmail, hotmail, or
any other browser email, you will need to install Windows Live Mail (it is free and you can continue to use email
as before, if you wish)
Note for Outlook Users:
a) you must use the 32 bit version, not the 64 bit version
b) Check the “use MS dll” box
c) For some versions, you MUST have Outlook open when you email from CS Ledger. Otherwise, Outlook
would ask a security question and the email may sit in the outbox
d) For some versions, you should always "Edit" the email; otherwise, Outlook would ask a security question
and may not include the attachment
e) See the Outlook settings in Help -> Outlook
f) If you have corrected settings as described in d) and attachments are still being sent as a .dat attachment or
as HTML in the body, then try the Resolve Name check box here. However, this will cause Outlook to
ask you to verify that it is ok to send
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Under Accounts, you can change the Default accounts but not the Restricted Accounts. Changing the default
accounts is only useful later if you add another account you want as the default, such as a 2 nd checking account..
You can change any of these accounts by changing the Account # in FILES -> ACCOUNTS
Under Display, you can change the wallpaper or choose different colors for the options shown. (recommended)
4.

select ADMIN -> USERS and add the users you want
“ADMIN” is the default.
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FILES
Accounts
select FILES -> ACCOUNTS
Here you can add or change the accounts as needed.
Title accounts are x0000 or xx000 and they group the accounts for the P&L and Balance Sheet. The x0000 title accounts are
set and cannot be deleted or the # changed (you can change the name). You add the xx000 title accounts you want. All
accounts under the title account are grouped and subtotaled. If there are no accounts under a title account, nothing will
be printed. For example, if you do not need both Operating Expenses 6xxxx and General & Admin Expenses 7xxxx
groups (you want only one), then you can change all the 7xxxx accounts to 6xxxx accounts or vice versa, or you can just
not use the accounts under one or the other.
The fiscal year is set for a calendar year. All accounting is done on an accrual basis. Net Earnings is automatically
transferred to Retained Earnings at the start of a new year. If necessary, you can adjust for cash basis from the balance
sheet for AR and AP.
To setup the beginning balances, enter a GL Transaction for the values you want with the date for the balances.
Note that the Retained Earnings and Net Earnings accounts are maintained by the system. To enter end of last year
Retained Earnings, enter the appropriate P&L data with the date of 12/31/<last yr>. This can be as simple as Sales and
Checking or your entire P&L totals. For Net Earnings YTD, do the same with last month’s date
Ledger will show the details of the account, which you can print.

Sales Reps
select FILES -> SALES REPS
If you use Sales Reps, you can enter them here along with their commission %.

Customers & Vendors
select FILES -> CUSTOMERS or VENDORS
Here you can add or change customers and vendors.
The Additional Information is the defaults that are used for transactions.
History will show the details of the customer or vendor, which you can print.

Items
select FILES -> ITEMS
Customer Orders/Invoices, Vendor Orders/Invoice, and Inventory Adj use items for transactions.
Stock items are standard inventory items that you want to keep track of. These are placed in inventory when purchased
and removed from inventory and charged to Cost Of Sales account when sold. Average Cost is used. ( See
customer/vendor invoices below.)
Non-Stock items are also physical items you sell but that you do not want to keep track of. These are charged to the
Purchase Account when bought.
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Other items are can be anything else. Examples are services you buy and/or sell, subcontracting, fixed assets where the
“Purchase Account” is an asset account, Investment Transactions, etc.
Decimals determines if decimals are needed or used (e.g. hours, feet, gals, thousands, etc)
History will show the details of the item usage, which you can print.

Import Specifications
Select FILES -> IMPORT SPECIFICATIONS
Here is where you define the different CSV formats for downloading CSV files. These can be for credit cards, bank
statements, or any other online institutions that allow you to download a CSV file. You only have to do this once for each
institution. Each periods files can then be downloaded and imported into Bills/Checks or GL Transactions

Lists
select FILES -> LISTS
You can add or edit the various lists, as needed.
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TRANSACTIONS
Customer Invoices/Orders/Sales
select TRANSACTIONS -> CUSTOMER INVOICES/ORDERS
The same transaction is used for Quotes, Orders, and Invoices; just change the status as appropriate.
Status “Sale” is used for immediate payment in full by the customer; “Invoice” is used for full/partial/credit payment
later. Accounts and Inventory are posted as of the invoice date
Print will print, email, or fax the transaction.

Customer Returns
select TRANSACTIONS -> CUSTOMER RETURNS
This transaction is used for returns from customers
Status “Refund” is used for immediate refund to customer; “Credit” is used for later credit in Receipts. The Return credit
amount is applied to invoices with a Receipt/Credit
Print will print, email, or fax the transaction.

Customer Receipts/Credits
select TRANSACTIONS -> CUSTOMER RECEIPTS/CREDITS
The same transaction is used for receipts and credits and is applied to the invoices. Customer Return credits are also
applied here
Discounts per invoice are allowed (eg 1% 10) as well as a general Credit. Entering a discount % in “Apply Disc %” will
automatically apply it for each invoice you click pay or “Auto Apply”
Print will print, email, or fax the transaction.

Vendor Invoices/Orders/Purchase
select TRANSACTIONS -> VENDOR INVOICES/ORDERS
The same transaction is used for RFQ’s, Orders, and Invoices; just change the status as appropriate.
Status “Purchase” is used for immediate full payment to vendor; “Invoice” is used for full/partial/credit payment later.
Accounts and Inventory are posted as of the invoice date
Print will print, email, or fax the transaction.

Vendor Returns
select TRANSACTIONS -> VENDOR RETURNS
This transaction is used for returns to vendors
Status “Refund” is used for immediate refund by vendor; “Credit” is used for later credit in Payments. The Return credit
amount is applied to invoices with a Payment/Credit
Print will print, email, or fax the transaction.
7

Vendor Payments/Credits
select TRANSACTIONS -> VENDOR PAYMENTS/CREDITS
The same transaction is used for payments and credits and is applied to the invoices. Vendor Return credits are also
applied here
Discounts per invoice are allowed (eg 1% 10) and a total Credit is also allowed. Entering a discount % in “Apply Disc %”
will automatically apply it for each invoice you click pay
Print will print the check.

Pay Bills/Checks
select TRANSACTIONS -> PAY BILLS/CHECKS
This will write a check to pay a bill without entering an invoice or item; you debit or credit the accounts directly. You can
import any CSV file you have defined and downloaded. When you import, you can define a “phrase” and account for
each line that will then be used to automatically reset the acct when you import the next time.
Print will print the check.

Time and Expense Sheets
select TRANSACTIONS -> TIME AND EXPENSE SHEETS
Time sheets are used for billing customers and/or paying expenses. Time sheets can be easily entered by User or Job.
These can then be loaded in Customer Invoices or Pay Bills (employee/contractor/professional expenses)
Print will print, email, or fax the time sheet.

Inventory Adjustments
select TRANSACTIONS -> INVENDORY ADJUSTMENTS
This is used for any changes needed to inventory (loss, breakage, etc.)

GL Transactions
select TRANSACTIONS -> GL TRANSACTIONS
This is used for all direct account entries. You can import any CSV file you have defined and downloaded.
You should NOT make any entries to the Net Earnings or Retained Earnings accounts; the system will do this
automatically.
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Personal Finance
You can use CS Ledger for your personal finances also.
The “traditional” way would be:
- input your income(s) as an invoice with status “Sale”
- pay bills by Pay Bills
- enter bank interest, debits, withdrawals, etc. under GL Transaction.
However, you can also just do the very simple method:
- pay all of your bills by credit cards, debit cards, checks, ATM, etc. without making any entries
- once/month download and input the bank transactions csv file in Pay Bills; it should automatically balance since it
contains all transactions
- for each credit card you want to break down, download the appropriate csv file and use Pay Bills to enter in the
details, deleting the payment line from last month; then edit and delete the line in the bank transactions bill that
paid the credit card
Under either method, you would create all the accounts you need to categorize your finances such as wages, doctor,
dentist, pharmacy, food, clothing, house maintenance, rent, cash withdrawal, etc. Then print a P&L to see this at a glance.
Refer to Reports to see about further detail you can print.
For further detail on the P&L, you can subdivide accounts; for example, you could have a “title” account “74000
Clothing” with sub accounts 74100 Macy’s, 74200 Target, … and then on the P&L you would get the individual accounts
and the total Clothing. Note that nothing is set in stone; you can create or delete title accounts and/or change account
numbers at any time.
When you input a downloaded csv file, you can, optionally, input the Key Phrase and Acct in the input screen. This way
the system will remember and fill in automatically the next time. The Key Phrase is the part of the input description line
that would not change, like Macy’s, Verizon, etc., while the total description will change from one month to the next
because of check #, date, etc.
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REPORTS
All reports have a bottom SEND TO: section where you choose where to send the report.

-

For Screen/Printer the report is first previewed on the screen and then you can send to any printer/device

-

For Printer you can send directly to any printer and the # copies to print.

-

For Email, the system will default to an email address if it can, but you can also click the To: to choose from all the
program contacts. When you click Report, the system will bring up your email client and you can add other
attachments (like artwork) and other contacts from your email list.

-

For File, the system allows you to save the report in many different formats.

-

For Fax, you can choose from the program contacts and the fax(s) are sent automatically. You can also fax by
choosing Screen/Printer and sending to the fax printer; this allows you to add a cover page etc. but you must input
the phone number(s) manually. Note that you must setup Email and Fax before using (see the Setup section)

For many reports, there is a SELECT – REPORT option at the top of the report screen This allows you to choose your own
criteria for the report and, optionally, save it for later recall. To use this, select the [New Select] from the dropdown list
(or a previously saved report and Edit).
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It is from this dialog box that you will select the conditions to create your reports. All conditions for level 1 will be
evaluated 1st, all for level 2 next, etc.
(level1 conditions) <logic2> (level2 conditions) <logic 3> (level3 conditions) ….
Where <logic2> is the logical condition starting level 2, <logic3> is the logical condition start level 3, etc
For the above example, this would be:
(Qty on Hand = 0 and Last Sold = This Month) or (Qty on Order = 0 and Last Sold = Before This Month)
NOTE: case does not matter and all character values mean “starting with” unless you choose oper “..Exactly..”
If you fill in the Report Name, the report will be saved and the next time you want to run it, you would choose it as noted
in previous figure. For saved reports that use dates (as above), you should use the non-specific operators like “Today”,
“This Month”, etc instead of specific date like “Between” with dates. That way, you will not have to change the dates
when you run it next time.
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Contact Management
CS Ledger incorporates a simplified contact management system. The features are:

Contact lookup. Press F6 or choose Contacts from the File menu. You are presented with a complete list of all contacts
for instant lookup with all the power of our standard grids. You can then edit, email, or send letters for any of these
contacts.

Contact Follow Up. You can set a follow up date for any customer.
Customer and Vendor Status. You can add additional Status values by choosing Files -> Lists -> Customer Status
or Vendor Status.
For example, you could add the status “Prospects” to the Customer Status list. This can be very useful to be able to
quickly view the Prospects in your Customer file. Or you could send an email to all of them under Reports -> Customer
Email.

Letter Templates. Choose Letter Templates from the File menu. Here you can Add or Edit templates.
You must have MS Word 2003 or later to use Templates or Letters. The format of the letters is set by the extension you
choose; “.DOC” for standard MS Word document (default), “.RTF” for rich text format, and “.TXT” for plain text format.
Add any standard letters you may want to send your customers (Thank You for meeting with you, Seeking a meeting,
etc.) These should be a letter without any salutation or address. Some examples have been loaded for you.

Right Click. You can right click anywhere in any of the Files or Transactions to choose to send an email or write a
letter. For a letter, you will be presented with the Letter Template you choose merged into a temporary document with
the address filled in. For example, when you Edit a customer, you can right click and send an email or letter to the
customer, any of the contacts, any of the ship to addresses, or to the billing address. After printing or emailing (from
Word), you would normally not save the merged document.
You can define additional Status terms for customers or vendors by choosing Files->Lists. For example, you can add the
status Prospect to the customer status and enter all your prospects in the customer files. You can then apply a filter to the
customer grid to only show Prospects whenever you want.
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General Procedures
Grids are the spreadsheet style forms that are opened when you click on any Transactions or Files on the main menu. For
example, FILES -> CUSTOMERS
From these, you can do an incredible number of things as indicated by the buttons on the right. In addition to these
functions, you can customize each grid to your preference.

Grid Preferences
You can change settings for each grid and save those preferences.
You can:
-drag columns to new positions
-change the width of a column
-set the order you wish
After you have it the way you want, click on SYSTEM-> PREFERENCES-> SAVE PREFERENCES.
You can restore the default preferences or clear all your preference settings at any time.

Grid Seek Function
To quickly find something within the entire data set, use the “Seek” function. Put the cursor anywhere in any column
with a bold header. For instance, if you wish to find a specific customer within the Customer Returns transactions,
put the cursor anywhere in the customer column. Press F8 on your computer keyboard and the SEEK window will
appear in the upper right of the grid. Start typing the name of the customer you are looking for and CS Ledger will go
to the first entry for that customer. To find a specific reference number, use the Seek function in the same manner. To
turn off the Seek Function, press F8 a second time. The Seek Function will automatically turn off when you open a
form.
To find something in a column that is not bold or to find something that is contained within a field, put the cursor in
the column you want and click the Find button.

Grid Sorting
The easiest and fastest way to sort is to double click the field heading, (i.e. Customer, or Follow up Date, etc.

Grid Filter
Filters are an easy way to quickly look at any subset of the data that you want. You first define subsets of the data
and then choose the one you want depending on what you are doing at the time.
For example, for the Invoice/Order grid you can define a filter for “Status=Order”, another for “Status=Quote”,
another for “Orders this month”, another for “Follow up this month”, etc. and then choose any of them after you
open the grid.
Another example would be to define a filter for “Status=Prospect” in the customer grid for viewing only propects.
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Security and User Restrictions
There is no such thing as perfect security. All systems, including fingerprint, eye scan, card
reader, encryption etc, can be broken.
CS Ledger security is based on user passwords. Passwords are the simplest type of security. Many computer experts can
usually break any password scheme. However, the password scheme in CS Ledger does insure that the person bypassing
it has to be deliberately doing so. Therefore, if it does happen, you know that the person or persons doing it can not claim
it was careless or by accident.
However, the password scheme does not have to be broken for the system to be compromised. The most common
security breach is people using easily guessed passwords, or leaving the written passwords lying around for anyone to
see, or one person giving their password to another due to illness, out of office, etc. It is your responsibility to see that
these types of things do not happen.
The only reason to use passwords is to restrict what some users can do. There are 2 types of user restrictions; Menu
Restrictions and Sales Rep Restrictions. If you are going to use passwords at all, you must use Menu Restrictions to create
at least 2 groups and only allow one group to have rights to Users and Groups; otherwise, anyone could goto Admin ->
Users or Groups and change them.
To input or change a user’s password, goto Admin -> Users, edit the User you want, and type the new password in; after
you leave the field, the password changes to the encrypted text. You can also blank out the Password field to remove the
password entirely (you may need to do this if the user forgot their password)
Users can change their passwords by System -> Change Password. If you use passwords, it is a good idea to have each
user change their password periodically. To do this, goto Admin -> Setup and set the “Advise password change” to the
value you want. Each user will then be reminded to change their password.

Menu Restrictions: Groups and Rights
You can restrict what menu choices your users can do by assigning them to groups. Each group is going to have a
set of permissions and restrictions and all users in that group will have that set of permissions and restrictions. To
do this, follow these steps.
1. Decide on how many groups you need; for example, you could have 2 groups, “Admin” and “Sales” where
Admin is going to have full rights and Sales is going to have restricted rights (many businesses will not need more
than 2 groups like this) or you could have a third group “Managers” that have Report rights and/or Backup
Restore Fix where Sales does not.
2. goto Admin -> Groups and Add both groups
3. The grid column Menu Choice lists all the Menu choices; for example, Admin refers the entire Admin menu
choice, Admin:Backup refers to the Backup choice under the Admin menu choice, etc
4. Menu Rights refers to the rights that this group has for all the menu choices; the rights are:
Write

= complete read, write, lookup rights

Read

= read only (can look at but cannot change)

Lookup = can lookup in selecting only
None

= can do none of the above
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5. Prg Rights are not used; they are reserved for future use.

NOTE: there are 2 important rules here
1. At lease one group must have full Admin rights (no restrictions) and at least one user must be in that group or
else you cannot do anything here again !!
2. The Admin user cannot “forget” their password; if you do, THERE IS NO WAY YOU CAN RECOVER IT !! If a
Sales Group user forgets their password, an Admin user can assign a new one for them.

Sale Rep Restrictions
Sales Rep restrictions do not restrict the users in the use of any menu choice. Instead, it restricts the information
they see in Transactions or Customers or Customer Reports to only those customers or transactions having that
sales rep or a blank sales rep A blank sales rep allows you to have one customer serviced by more than one sales
rep; each would only see their transactions.
To do this, goto Admin -> Users and select the sales rep you want this user restricted to under the column Restrict
To.

You can, of course, use both type of restrictions, Menu and Sales Rep, at the same time.

Networks and other users
If you have other users that you do not want to have any access to CS Ledger, you can restrict access to the
directory to only the users you want by using the security restrictions in Windows. Please refer to Windows for
doing this.
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Crashes, Back Ups and Common Problems
System Crashes
A system crash occurs when your computer “locks up” and you can no longer perform any functions, requiring you to reboot your machine. There are many reasons you could experience a crash such as a power failure, a power surge, a
Windows malfunction, a problem with another program running in the background, etc. At this point in time, there is no
way to guarantee that your computer will never crash. And unfortunately, computer crashes occasionally result in
corrupted data.

Fix and Optimize
Most of the time, a system crash will not corrupt data. However, if your data is corrupted, you can run Fix & Optimize
under the Admin Menu which will correct corrupted data about 90% of the time
If you are unable to open CS Ledger due to a system crash, you will not be able to access the Fix & Optimize option within
the program. In this case, you can run the Fix and Optimize on startup by adding (space) /F at the end of the Target line
in of the icon.

Back Ups
CS Ledger includes a backup utility under Admin that makes a zip backup of the data files

The Program Directories
When you install CS Ledger, the program files will be loaded into C:\APPS\CSLEDGER unless you specify another
default during installation. The program directory holds only the CS Ledger program files. If you suspect that these
program files have become corrupted, you can simply re-install CS Ledger. The setup program will re-install any
corrupted program files without disturbing any of your data files.
Beneath the program directory is the data directory that contains all of your company’s data. Unless you specified another
default during installation, this directory is known as C:\APPS\ CSLEDGER\DATA. When making backups, you must
back up the information in this data directory.

Alternate Backup Method
As an alternate to the Windows backup utility or the built in data backup of CS Ledger, you can make a CD backup of the
entire CS Ledger Program Directory. This allows you to save both the program and data at a point in time. You can then
run this backup at any time! For example, you use this method of making a backup at the end of every year on 12/31 or
1/1 and then, at any future date, you can insert the disk and run CS Ledger as though it was that date, no matter what

program or data changes have occurred since then. In addition, this makes an excellent backup in case of any
disaster such as a crash, fire, stolen etc.

Internet/Remote Connection
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There are 3 general situations:
1. You need to access and add or edit from a remote location; and you need the office personnel to do the same at the
same time; and/or multiple people will be accessing remotely. In this case, install Terminal Server on your office
computer and then setup your home computer to access; this is the most secure method and allows multiple people to
connect from remote sites, at the same time
2. You need to access and add or edit from a remote location but no one else uses the software. In this case, you can
always do 1 above or use remote control software to connect from the remote location (e.g. LOGMEIN) This is much
simpler but less secure and only 1 person at a time can connect
3. You only need to view the data on your laptop; you can do 1 or 2 above or you can periodically back up your entire
program directory to a CD and copy it to your laptop; this provides both a backup and a copy to view This does not
require an internet connection (see Alternate Backup).
Note that Citrix provides a mobile phone app that can also be used similar to Terminal Server and that works well with
tablets like iPad.

17

Error Messages
Q. I am using Vista and the borders and headers are jumbled or missing.
A. This is a known Microsoft Vista problem. It occurs in ALL programs that perform a certain action in a certain
sequence. Unfortunately, our program does just that. Until Microsoft fixes the problem in Vista, the only solution is to
run the program as Administrator or turn off Aero in Vista.
Q. When I try to email or fax from CS Ledger, I get the error “Postscript Printer not found” or “Fax Printer not found”
A. Please refer to the manual section Setting up Email and Fax Capability. The printers you defined under Admin when
setting up email and fax must be set up as local printers on every computer on the network and must be exactly the same.
Q. Why do my PDF Email attachments appear jumbled when opened by Acrobat ?
A. The PDF attachments created by CS Ledger require Acrobat Reader 5.0 or later.
Q. Email or Fax attachments have too small or too large fonts.
A. This is probably due to the PostScript printer you installed. You must install a local Postscript printer on every
computer that will Email or Fax. In addition, the must be the same on every computer and must be chosen under Admin
-> Setup. We recommend using the HP Color Laserjet PS since we know this driver works (Printer drivers are very
difficult to write and the printer manufacturers often have bugs.)
Q. Email fails with message “…GhostScript Error 259…” or similar
A. This is probably because the printer chosen in Admin -> Setup does not exist on your system or is not a postscript
printer.
Q. Email fails with message “…MAPI could not be loaded…”
A. If you are using Windows NT/2000/XP then right click the CS Ledger icon and choose “Run as …” and choose to ran
as administrator. If you are using Vista or 7/8, right click the CS Ledger icon and choose “Run as Administrator”.
Assuming it works, you can then run normally in the future.
If it doesn’t work, please contact CS Ledger support.
Q. Email from CS Ledger has suddenly stopped working
A. There can be a number of reasons for this.
1. Make sure that you are using a MAPI compliant email client program such as Outlook, Outlook Express, Windows
Mail, or Windows Live Mail (see Setting up Email and Fax Capability).
2. If you are using Outlook, make sure it is the 32 bit version, not the 64 bit version
3. Make sure that you can send and receive email from your email program. You must be able to do this for our program
to send email
4. Make sure that Internet Explorer is set for your email program.
Q. Faxing or Emailing from CS Ledger fails with Error 1426, OLE CODE 0x80070035
A. This code means that one of the OLE modules cannot find your file path. This is usually one of 3 reasons.
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1. The path for the program under properties of the CS Ledger icon uses UNC paths (e.g. the Target line has something
like \\othermachine\folder\csledger\csledger.exe ). To fix this, map the drive with a letter and change the target line to
use the letter (e.g. x:\csledger\csledger.exe)
2. The path for the program under properties of the CS Ledger has spaces in it (e.g. the Target line has something like
G:\My Apps\csledger\csledger.exe). To fix this, change the folder name to use underscores instead of spaces (e.g.
My_Apps). This usually does not cause a problem, but give it a try.
3. Your machines temporary files path is too long or contains spaces. To fix this, change your temporary file paths as
follows:
3.1. Make sure you have a folder (directory) on your computer of: C:\TEMP
3.2. Click on Start -> Settings -> Control Panel to open control panel.
3.3. Open System and click on the Advanced tab
3.4. Click on the button labeled Environment Variables
3.5. Change both the variable TEMP and TMP to C:\TEMP
3.6. Save and Restart your computer
Q. The program starts with a message that includes “…invalid path or file name…” or with a message that includes
“…NTVDM…”
A. You may have a corrupted program file.
1. Download and install the latest program from our web site www.csledger.com
2. If this does not work, adjust the temporary files path as described in step 3 above.
3. If this does not work see the next question.
Q. The program starts with a message “C:\Winnt\System32\<…>.nt The system file is not suitable for running MSDOS and Microsoft Windows applications. Choose 'Close' to terminate the application.”
A. One of your files CONFIG.NT, AUTOEXEC.NT, or COMMAND.COM has been deleted, corrupted, or moved.
can happen from a virus or some cleanup programs downloaded from the web.

This

Not all programs use or need these files (unfortunately, ours does). Microsoft article #324767 describes this problem and
how to fix it. Until you get this fixed, you can try clicking “Ignore”; if the CS Ledger system comes up, you can run it
without worry (some things may not work but will not harm your system or data)
Q. When I try to run the program, I get “VFP Cannot Start. Could not load Resources”
A. This means that the runtime files for VFP could not be loaded. The most likely cause of this is that you installed the
program or upgrade logged in as one user and you are trying to run logged in as another user.
This could also be caused by corrupted or missing runtime files.
The solution to both is to reinstall the program (this will not harm you data). If this does not work, try deleting all the
files in the program directory (BUT NOT THE DATA DIRECTORY) and then reinstalling.
Q. The program starts with a message “System is Read Only” and does not work
A. CS Ledger is reporting that the System files are marked Read Only. You probably restored the data from a CD. To fix
this, make sure all files in the Data directory are not marked read only (see Windows Help).
Q. The program starts with a message “System is Currently Shutdown” and does not work
A. This is VERY unusual but it could happen if you are running Fix and Optimize and your computer crashes while this
is being run (e.g. power failure, etc.) To fix this, remove the file SHUTDOWN from the data directory.
Q. We have a multiple users and sometimes when we have all users inputting data we get corrupt data or index.
A. You probably have a Windows locking problem. Please see LOCKING.RTF in the CS Ledger docs folder.
19

Q. You occasionally get a “…Delayed Write Failure…”
A. You need to disable write caching; see LOCKING.RTF in the CS Ledger docs folder.
Q. Backup to a CD drive fails
A. The problem is most likely that you have what is called buffer underrun. Instead of making the backup directly to the
CD, first make the backup to your hard drive (e.g. C:\CSDATA.ZIP) and then copying that file to the CD.
Q. My computer crashed and Restore does not work.
A. If the problem is Bad Media or a Bad Zip File, then the only thing you can do is try another backup to restore. If the
restore appears to work but the program does then not run, try reinstalling the latest CS Ledger program. If this does not
work, email us at techsupport@csledger.com and we’ll try to help.
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